<!doctype html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="http://gmpg.org/xfn/11">
	
	<!-- Google Search Console -->
	<meta name="google-site-verification" content="YN469yBfYj2CRyh8UtshXrp3taoHrUixxz-deeQm4oY" />
	
	<!-- Global site tag (gtag.js) - Google Analytics -->
	<script async src="https://www.googletagmanager.com/gtag/js?id=UA-138994255-1"></script>
	<script>
		window.dataLayer = window.dataLayer || [];
		function gtag(){dataLayer.push(arguments);}
		gtag('js', new Date());
		gtag('config', 'UA-138994255-1');
	</script>

	<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
    <script>
      (adsbygoogle = window.adsbygoogle || []).push({
        google_ad_client: "ca-pub-9010558195689423",
        enable_page_level_ads: true
      });
    </script>

	<title>How to Open Ports in Ubuntu (Guide) - sudoadmins</title>

<!-- This site is optimized with the Yoast SEO plugin v11.0 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="In Ubuntu, there is an application called UFW (Uncomplicated Firewall) that makes it much easier to manage IPTables in Ubuntu. As such, IPTables is the firewall of Linux systems, but it is somewhat difficult to work with. But, UWF is very easy to use."/>
<link rel="canonical" href="http://sudoadmins.com/how-to-open-ports-in-ubuntu-guide/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to Open Ports in Ubuntu (Guide) - sudoadmins" />
<meta property="og:description" content="In Ubuntu, there is an application called UFW (Uncomplicated Firewall) that makes it much easier to manage IPTables in Ubuntu. As such, IPTables is the firewall of Linux systems, but it is somewhat difficult to work with. But, UWF is very easy to use." />
<meta property="og:url" content="http://sudoadmins.com/how-to-open-ports-in-ubuntu-guide/" />
<meta property="og:site_name" content="sudoadmins" />
<meta property="article:section" content="Guides" />
<meta property="article:published_time" content="2020-05-19T20:32:32+00:00" />
<meta property="og:image" content="http://sudoadmins.com/wp-content/uploads/2020/05/ports.png" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="720" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="In Ubuntu, there is an application called UFW (Uncomplicated Firewall) that makes it much easier to manage IPTables in Ubuntu. As such, IPTables is the firewall of Linux systems, but it is somewhat difficult to work with. But, UWF is very easy to use." />
<meta name="twitter:title" content="How to Open Ports in Ubuntu (Guide) - sudoadmins" />
<meta name="twitter:image" content="http://sudoadmins.com/wp-content/uploads/2020/05/ports.png" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"http://sudoadmins.com/#organization","name":"Sudo Admins","url":"http://sudoadmins.com/","sameAs":[]},{"@type":"WebSite","@id":"http://sudoadmins.com/#website","url":"http://sudoadmins.com/","name":"sudoadmins","publisher":{"@id":"http://sudoadmins.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"http://sudoadmins.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"http://sudoadmins.com/how-to-open-ports-in-ubuntu-guide/#webpage","url":"http://sudoadmins.com/how-to-open-ports-in-ubuntu-guide/","inLanguage":"en-US","name":"How to Open Ports in Ubuntu (Guide) - sudoadmins","isPartOf":{"@id":"http://sudoadmins.com/#website"},"image":{"@type":"ImageObject","@id":"http://sudoadmins.com/how-to-open-ports-in-ubuntu-guide/#primaryimage","url":"http://sudoadmins.com/wp-content/uploads/2020/05/ports-363x188.png","caption":""},"primaryImageOfPage":{"@id":"http://sudoadmins.com/how-to-open-ports-in-ubuntu-guide/#primaryimage"},"datePublished":"2020-05-19T20:32:32+00:00","dateModified":"2020-05-19T20:32:32+00:00","description":"In Ubuntu, there is an application called UFW (Uncomplicated Firewall) that makes it much easier to manage IPTables in Ubuntu. As such, IPTables is the firewall of Linux systems, but it is somewhat difficult to work with. But, UWF is very easy to use."},{"@type":"Article","@id":"http://sudoadmins.com/how-to-open-ports-in-ubuntu-guide/#article","isPartOf":{"@id":"http://sudoadmins.com/how-to-open-ports-in-ubuntu-guide/#webpage"},"author":{"@id":"http://sudoadmins.com/author/jeffmitchell/#author","name":"Jeff Mitchell"},"publisher":{"@id":"http://sudoadmins.com/#organization"},"headline":"How to Open Ports in Ubuntu (Guide)","datePublished":"2020-05-19T20:32:32+00:00","dateModified":"2020-05-19T20:32:32+00:00","commentCount":0,"mainEntityOfPage":"http://sudoadmins.com/how-to-open-ports-in-ubuntu-guide/#webpage","image":{"@id":"http://sudoadmins.com/how-to-open-ports-in-ubuntu-guide/#primaryimage"},"articleSection":"Guides"},{"@type":"Person","@id":"http://sudoadmins.com/author/jeffmitchell/#author","name":"Jeff Mitchell","image":{"@type":"ImageObject","@id":"http://sudoadmins.com/#personlogo","url":"http://1.gravatar.com/avatar/12052161e28e0b83b9712f7251e3992c?s=96&d=mm&r=g","caption":"Jeff Mitchell"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//sudoadmins.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="sudoadmins &raquo; Feed" href="http://sudoadmins.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="sudoadmins &raquo; Comments Feed" href="http://sudoadmins.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/sudoadmins.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.1.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='http://sudoadmins.com/wp-includes/css/dist/block-library/style.min.css?ver=5.1.5' type='text/css' media='all' />
<link rel='stylesheet' id='justread-style-css'  href='http://sudoadmins.com/wp-content/themes/justread/style.css?ver=1.0.0' type='text/css' media='all' />
<link rel='https://api.w.org/' href='http://sudoadmins.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://sudoadmins.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://sudoadmins.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.1.5" />
<link rel='shortlink' href='http://sudoadmins.com/?p=305' />
<link rel="alternate" type="application/json+oembed" href="http://sudoadmins.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fsudoadmins.com%2Fhow-to-open-ports-in-ubuntu-guide%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://sudoadmins.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fsudoadmins.com%2Fhow-to-open-ports-in-ubuntu-guide%2F&#038;format=xml" />

<!-- StarBox - the Author Box for Humans 3.2.6, visit: http://wordpress.org/plugins/starbox/ -->
<!-- /StarBox - the Author Box for Humans -->

<link rel='stylesheet' id='ABHfrontend.min.css-css'  href='http://sudoadmins.com/wp-content/plugins/starbox//themes/fancy/css/frontend.min.css?ver=3.2.6' type='text/css' media='all' />
<script type='text/javascript' src='http://sudoadmins.com/wp-content/plugins/starbox//themes/fancy/js/frontend.min.js?ver=3.2.6'></script>
<link rel='stylesheet' id='ABHhidedefault.min.css-css'  href='http://sudoadmins.com/wp-content/plugins/starbox//themes/admin/css/hidedefault.min.css?ver=3.2.6' type='text/css' media='all' />
</head>

<body class="post-template-default single single-post postid-305 single-format-aside">
<div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<div class="form-wrapper" id="form-wrapper">
		<button class="search-close" id="search-close">&times;</button>
		<form role="search" method="get" class="search-form" action="http://sudoadmins.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input class="search-field" placeholder="Search &hellip;" value="" name="s" type="search">
	</label>
</form>
	</div>

	<header id="masthead" class="site-header">
		<div class="navbar">
			<div class="site-branding">
									<p class="site-title"><a href="http://sudoadmins.com/" rel="home">sudoadmins</a></p>
										<p class="site-description">A Resource For Linux Sysadmins</p>
							</div><!-- .site-branding -->

			<nav id="site-navigation" class="main-navigation">
				<ul id="primary-menu" class="menu"><li id="menu-item-74" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-74"><a href="http://sudoadmins.com/">Home</a>
<ul class="sub-menu">
	<li id="menu-item-296" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-296"><a href="http://sudoadmins.com/about/">About</a></li>
	<li id="menu-item-290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-290"><a href="http://sudoadmins.com/contact-us/">Contact Us</a></li>
	<li id="menu-item-249" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-249"><a href="http://sudoadmins.com/write-with-us/">Write With Us</a></li>
	<li id="menu-item-297" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-297"><a href="http://sudoadmins.com/privacy-policy/">Privacy Policy</a></li>
</ul>
</li>
<li id="menu-item-90" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-90"><a href="http://sudoadmins.com/category/guides/">Guides</a></li>
<li id="menu-item-91" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-91"><a href="http://sudoadmins.com/category/commands/">Commands</a></li>
<li id="menu-item-92" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92"><a href="http://sudoadmins.com/category/tipsandtricks/">Tips &#038; Tricks</a></li>
</ul>			</nav><!-- #site-navigation -->
		</div>
		<div class="social-icons">
						<button class="search-toggle" aria-controls="form-wrapper" aria-expanded="false"><svg class="icon icon-search" aria-hidden="true" role="img"> <use href="#icon-search" xlink:href="#icon-search"></use> </svg></button>
			<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">Menu</button>
		</div>
	</header><!-- #masthead -->

	<div id="content" class="site-content">

	<div id="primary" class="content-area">
		<main id="main" class="site-main">

		
<article id="post-305" class="post-305 post type-post status-publish format-aside has-post-thumbnail hentry category-guides post_format-post-format-aside">
	<header class="entry-header">
		<h1 class="entry-title">How to Open Ports in Ubuntu (Guide)</h1>					<div class="entry-meta">
				<span class="byline"> <img alt='' src='http://1.gravatar.com/avatar/12052161e28e0b83b9712f7251e3992c?s=32&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/12052161e28e0b83b9712f7251e3992c?s=64&#038;d=mm&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /> <span class="author vcard"><a class="url fn n" href="http://sudoadmins.com/author/jeffmitchell/">Jeff Mitchell</a></span></span><span class="posted-on"><span class="on">on</span><a href="http://sudoadmins.com/how-to-open-ports-in-ubuntu-guide/" rel="bookmark"><time class="entry-date published updated" datetime="2020-05-19T20:32:32+00:00">May 19, 2020</time></a></span>			</div><!-- .entry-meta -->
			</header><!-- .entry-header -->

	<div class="entry-body">
					<div class="entry-media">
				<img width="1280" height="720" src="http://sudoadmins.com/wp-content/uploads/2020/05/ports.png" class="singular-thumbnail wp-post-image" alt="" srcset="http://sudoadmins.com/wp-content/uploads/2020/05/ports.png 1280w, http://sudoadmins.com/wp-content/uploads/2020/05/ports-300x169.png 300w, http://sudoadmins.com/wp-content/uploads/2020/05/ports-768x432.png 768w, http://sudoadmins.com/wp-content/uploads/2020/05/ports-1024x576.png 1024w" sizes="(max-width: 1280px) 100vw, 1280px" />			</div>
				<div class="entry-content">
			<h2>Introduction</h2>
<p>Having a Firewall configured and with the right rules is important to maintain the security of the system. To make a suitable configuration it is convenient to know how to open ports in distributions as popular as Ubuntu. Besides, if you install an application that requires Internet access through a certain port, then you will most likely need to open it. So, let&#8217;s get started.</p>
<p>In Ubuntu, there is an application called UFW (Uncomplicated Firewall) that makes it much easier to manage IPTables in Ubuntu. As such, IPTables is the firewall of Linux systems, but it is somewhat difficult to work with. But, UWF is very easy to use.</p>
<h2>Enabling UFW on Ubuntu</h2>
<p>UFW is installed by default in Ubuntu and any derivative of it. The detail is that it comes disabled by default. So I promise that you have to enable it.</p>
<p>So, open a terminal from the Ubuntu main menu. Once it is open, check that UFW is indeed disabled.</p>
<pre>sudo ufw status</pre>
<p>You probably have a screen output like this:</p>
<pre>Status: inactive</pre>
<p>Then, to enable it, just execute this command:</p>
<pre>sudo ufw enable</pre>
<p>Output:</p>
<pre>Firewall is active and enabled on system startup</pre>
<p>And now if you check the status of the UFW, it should indicate that it is active:</p>
<pre>sudo ufw status</pre>
<p>The screen output will have to be similar to this:</p>
<pre>Status: active</pre>
<figure id="attachment_318" aria-describedby="caption-attachment-318" style="width: 738px" class="wp-caption alignnone"><img class="size-full wp-image-318" src="http://sudoadmins.com/wp-content/uploads/2020/05/Enabling-ufw-ubuntu.png" alt="Enabling UFW on Ubuntu" width="738" height="206" srcset="http://sudoadmins.com/wp-content/uploads/2020/05/Enabling-ufw-ubuntu.png 738w, http://sudoadmins.com/wp-content/uploads/2020/05/Enabling-ufw-ubuntu-300x84.png 300w" sizes="(max-width: 738px) 100vw, 738px" /><figcaption id="caption-attachment-318" class="wp-caption-text">Enabling UFW on Ubuntu</figcaption></figure>
<p>Now you have successfully achieved the first step.</p>
<h2>How to open Ports on Ubuntu</h2>
<p>As a security policy, most of the Linux distributions, block all the input ports of our computer. Of course, this is also the case with Ubuntu.</p>
<p>However, if your computer offers a service to other members of the network or the Internet such as database, FTP, and others, then it is necessary to enable some ports. So, it is important, in that sense, to open only those ports that are strictly necessary.</p>
<p>The basic syntax is as follows:</p>
<pre>sudo ufw allow &lt;port&gt;</pre>
<p>For example, if you want to open the port 90 just run this command:</p>
<pre>sudo ufw allow 90</pre>
<p>Output:</p>
<pre>Rule added
Rule added (v6)</pre>
<p>In the previous example, the port 90 is opened for both TCP and UDP.</p>
<p>Also, it is possible to specify which protocol you want for that port. For example:</p>
<pre>sudo ufw allow 91/tcp</pre>
<p>Output:</p>
<pre>Rule added
Rule added (v6)</pre>
<p>The above command only enables TCP packets on port 91.</p>
<p>If you want to open the port by UDP, just replace <strong>tcp</strong> by <strong>udp</strong>.</p>
<pre>sudo ufw allow 91/udp</pre>
<p>Output:</p>
<pre>Rule added
Rule added (v6)</pre>
<figure id="attachment_319" aria-describedby="caption-attachment-319" style="width: 633px" class="wp-caption alignnone"><img class="size-full wp-image-319" src="http://sudoadmins.com/wp-content/uploads/2020/05/enable-ports-ubuntu.png" alt="Open Ports on Ubuntu" width="633" height="211" srcset="http://sudoadmins.com/wp-content/uploads/2020/05/enable-ports-ubuntu.png 633w, http://sudoadmins.com/wp-content/uploads/2020/05/enable-ports-ubuntu-300x100.png 300w" sizes="(max-width: 633px) 100vw, 633px" /><figcaption id="caption-attachment-319" class="wp-caption-text">Open Ports on Ubuntu</figcaption></figure>
<h2>Enabling connections by service</h2>
<p>Sometimes you do not know which ports you have to open and it is better to do it for services.</p>
<p>By enabling connection by service, what the UFW does is open the port associated with that service. This way you don&#8217;t have to know the port, but only the service you want.</p>
<p>The syntax is very similar only that the parameter you have to add is not a port but a service.</p>
<pre>sudo ufw allow &lt;service-name&gt;</pre>
<p>For example, if you want to enable SSH connections, just run this command:</p>
<pre>sudo ufw allow ssh</pre>
<p>Output:</p>
<pre>Rule added
Rule added (v6)</pre>
<figure id="attachment_320" aria-describedby="caption-attachment-320" style="width: 595px" class="wp-caption alignnone"><img class="size-full wp-image-320" src="http://sudoadmins.com/wp-content/uploads/2020/05/enabling-connections.png" alt="Enabling connections or the system service" width="595" height="120" srcset="http://sudoadmins.com/wp-content/uploads/2020/05/enabling-connections.png 595w, http://sudoadmins.com/wp-content/uploads/2020/05/enabling-connections-300x61.png 300w" sizes="(max-width: 595px) 100vw, 595px" /><figcaption id="caption-attachment-320" class="wp-caption-text">Enabling connections or the system service</figcaption></figure>
<p>If you want to know what other services are available on your system for use in UFW, you can run this command:</p>
<pre>sudo systemctl -r --type service --all</pre>
<figure id="attachment_321" aria-describedby="caption-attachment-321" style="width: 1365px" class="wp-caption alignnone"><img class="size-full wp-image-321" src="http://sudoadmins.com/wp-content/uploads/2020/05/list-all-system-service.png" alt="All system services" width="1365" height="688" srcset="http://sudoadmins.com/wp-content/uploads/2020/05/list-all-system-service.png 1365w, http://sudoadmins.com/wp-content/uploads/2020/05/list-all-system-service-300x151.png 300w, http://sudoadmins.com/wp-content/uploads/2020/05/list-all-system-service-768x387.png 768w, http://sudoadmins.com/wp-content/uploads/2020/05/list-all-system-service-1024x516.png 1024w" sizes="(max-width: 1365px) 100vw, 1365px" /><figcaption id="caption-attachment-321" class="wp-caption-text">All system services</figcaption></figure>
<h2>Disable ports on Ubuntu</h2>
<p>To reverse the changes you have previously made, simply reverse the process. That is, you have to disable the use of the ports in the system.</p>
<p>The syntax is quite similar to <strong>allow</strong>, except that the command after <strong>ufw</strong> is <strong>deny</strong>.</p>
<pre>sudo ufw deny &lt;port&gt;</pre>
<p>Also, you can specify the protocol as in the previous command.</p>
<pre>sudo ufw deny 90/tcp</pre>
<p>Or:</p>
<pre>sudo ufw deny 90/udp</pre>
<h2>Conclusion</h2>
<p>Now that you know how to open ports in Ubuntu you have no excuse to try and add even more security to your system. Also, you&#8217;ve learned how to disable it and increase security.</p>
<p>If you want more information you can check the entry dedicated to UFW in the <a href="https://help.ubuntu.com/community/UFW" target="_blank" rel="noopener noreferrer">Ubuntu wiki</a>.</p>

                         <div class="abh_box abh_box_down abh_box_fancy"><ul class="abh_tabs"> <li class="abh_about abh_active"><a href="#abh_about">About</a></li> <li class="abh_posts"><a href="#abh_posts">Latest Posts</a></li></ul><div class="abh_tab_content"><section class="vcard abh_about_tab abh_tab" style="display:block"><div class="abh_image"><a href = "http://sudoadmins.com/author/jeffmitchell/" class="url" title = "Jeff Mitchell" > <img src="http://sudoadmins.com/wp-content/uploads/gravatar/square-2.png" class="photo" width="250" alt="Jeff Mitchell" /></a > </div><div class="abh_social"> </div><div class="abh_text"><h3 class="fn name" ><a href="http://sudoadmins.com/author/jeffmitchell/" class="url">Jeff Mitchell</a></h3><div class="abh_job" ></div><div class="description note abh_description" ></div></div> </section><section class="abh_posts_tab abh_tab" ><div class="abh_image"><a href="http://sudoadmins.com/author/jeffmitchell/" class="url" title="Jeff Mitchell"><img src="http://sudoadmins.com/wp-content/uploads/gravatar/square-2.png" class="photo" width="250" alt="Jeff Mitchell" /></a></div><div class="abh_social"> </div><div class="abh_text"><h4 >Latest posts by Jeff Mitchell <span class="abh_allposts">(<a href="http://sudoadmins.com/author/jeffmitchell/">see all</a>)</span></h4><div class="abh_description note" ><ul>				<li>					<a href="http://sudoadmins.com/how-to-open-ports-in-ubuntu-guide/">How to Open Ports in Ubuntu (Guide)</a><span> - May 19, 2020</span>				</li></ul></div></div> </section></div> </div>		</div><!-- .entry-content -->

		<footer class="entry-footer">
			<span class="cat-links"><span class="cat-links__title">Categories</span><a href="http://sudoadmins.com/category/guides/" rel="category tag">Guides</a></span>		</footer><!-- .entry-footer -->
	</div>
</article><!-- #post-305 -->

	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links">
<article class="adjacent">
	<div class="card">
					<a class="card__media" href="http://sudoadmins.com/arch-linux-easy-install-guide/" title="Arch Linux Install for Beginners (Guide)">
				<img width="444" height="230" src="http://sudoadmins.com/wp-content/uploads/2019/04/boot-444x230.png" class="attachment-justread-adjacent size-justread-adjacent wp-post-image" alt="" srcset="http://sudoadmins.com/wp-content/uploads/2019/04/boot-444x230.png 444w, http://sudoadmins.com/wp-content/uploads/2019/04/boot-363x188.png 363w" sizes="(max-width: 444px) 100vw, 444px" />			</a>
				<div class="card__body">
			<header class="card__header">
														<a class="card__subtitle" href="http://sudoadmins.com/category/all/">All</a>
								<h3 class="card__title"><a href="http://sudoadmins.com/arch-linux-easy-install-guide/" rel="bookmark">Arch Linux Install for Beginners (Guide)</a></h3>			</header>

			<div class="card__content">
				<p>Learn the basic process for installing Arch Linux.</p>
			</div><!-- .entry-summary -->
		</div>
	</div>
</article>
</div>
	</nav>
		</main><!-- #main -->
	</div><!-- #primary -->


	</div><!-- #content -->

	<footer id="colophon" class="site-footer">
					<div class="footer-widgets grid grid--4">
				<section id="custom_html-3" class="widget_text widget widget_custom_html"><h4 class="widget-title">Advertisement</h4><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Top Bar Ad -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-9010558195689423"
     data-ad-slot="6373841047"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></section>			</div>
		
		<div class="site-info">
			<a href="https://wordpress.org/">
				Proudly powered by WordPress			</a>
			<span class="sep"> | </span>
			Theme: Justread by <a href="https://gretathemes.com">GretaThemes</a>.		</div><!-- .site-info -->
	</footer><!-- #colophon -->
</div><!-- #page -->

<script type='text/javascript' src='http://sudoadmins.com/wp-content/themes/justread/js/navigation.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://sudoadmins.com/wp-content/themes/justread/js/skip-link-focus-fix.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://sudoadmins.com/wp-content/themes/justread/js/script.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://sudoadmins.com/wp-includes/js/wp-embed.min.js?ver=5.1.5'></script>
<svg xmlns="http://www.w3.org/2000/svg" style="display: none;">
	<symbol id="icon-search" viewBox="0 0 1792 1792"><path d="M1216 832q0-185-131.5-316.5t-316.5-131.5-316.5 131.5-131.5 316.5 131.5 316.5 316.5 131.5 316.5-131.5 131.5-316.5zm512 832q0 52-38 90t-90 38q-54 0-90-38l-343-342q-179 124-399 124-143 0-273.5-55.5t-225-150-150-225-55.5-273.5 55.5-273.5 150-225 225-150 273.5-55.5 273.5 55.5 225 150 150 225 55.5 273.5q0 220-124 399l343 343q37 37 37 90z"/></symbol>

	<symbol id="icon-bookmark" viewBox="0 0 1792 1792"><path d="M1420 128q23 0 44 9 33 13 52.5 41t19.5 62v1289q0 34-19.5 62t-52.5 41q-19 8-44 8-48 0-83-32l-441-424-441 424q-36 33-83 33-23 0-44-9-33-13-52.5-41t-19.5-62v-1289q0-34 19.5-62t52.5-41q21-9 44-9h1048z" /></symbol>
</svg>

</body>
</html>
